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MÁSTER EN BIOCATALISIS APLICADA Y BIOTRANSFORMACIONES: PRACTICAS DE DOCKING  

INTRODUCCION 

Las enzimas se utilizan ampliamente en reacciones de síntesis orgánica como biocatalizadores 
sostenibles,

 [1,2] siendo las enzimas hidrolíticas especialmente útiles, ya que pueden ser utilizadas 
frente una amplia gama de sustratos con alta especificidad, son estereoselectivas, están 
disponibles comercialmente y no requieren costosos sistemas de regeneración del cofactor. 
Estos biocatalizadores se han utilizado en un gran número de aplicaciones industriales, como 
son la industria farmacéutica, química, alimentaria etc. [3,4] 

Los métodos in silico han sido desarrollados para predecir afinidad, actividad y selectividad en 
las proteínas basadas en su información estructural.[5] En el desarrollo de fármacos, el docking 
se utiliza habitualmente para identificar nuevos compuestos mediante la detección virtual de 
bibliotecas de pequeñas moléculas, [6] además, los métodos de docking también se aplican con 
éxito para predecir los sustratos más probables de enzimas con estructura conocida [7,8] 

El ácido (RS)-2-(4-isobutilfenil)propanoico (ibuprofeno) se usa como fármaco antinflamatorio no 
esteorideo (AINE), cómo antipirético, analgésico y antiinflamatorio. Esta molécula posee un 
centro estereogénico en la posición alfa con respecto al ácido carboxílico, lo que hace que 
coexista en forma de dos enantiómeros. En el caso del ibuprofeno, el enántiómero (S) es 160 
veces más activo que el enantiómero (R). Por lo tanto, es importante el uso de sólo el 
enantiómero activo, siendo un gran desafío separar estos enantiómeros para obtener una 
sustancia pura biológicamente activa. Los métodos clásicos para obtener enantiómeros puros 
vía la química tradicional son caros por lo que el uso de enzimas altamente enantioselectivas se 
muestra como una de las mejores alternativas para la síntesis de este tipo de compuestos.  

En el caso de los ácidos 2-arilpropiónicos los mejores candidatos para una resolución de los 
racematos (RS) son las lipasas ya que hidrolizan o esterifican solo uno de los enantiómeros. 
Particularmente la Lipasa de Candida Rugosa es la enzima empleada para separar el racemato 
(RS) del ibuprofeno, ya que solamente hidroliza el enantiómero (S). En esta hidrólisis están 
implicados tres residuos del centro activos, llamados triada catalítica, (SER-209, GLU 341 y HIS-
449). [9] 
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OBJETIVOS:  

Entender mediante la técnica de Docking la estereoselectividad de la lipasa de Candida Rugosa 
en la reacción de hidrolisis de ésteres, teniendo en cuenta las interacciones entre el ligando (RS) 
ibuprofeno y la triada catalítica (SER-209, GLU 341 y HIS-449). 
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MATERIAL 

-ZINC: Base de datos de estructuras de pequeñas moléculas 
-PDB: Base de datos de estructuras de proteínas 
- AUTODOCKTOOLS: Programa para preparar, realizar y visionar los ficheros de docking y sus 
resultados 
-AUTODOCK: Programa de docking 
-PYMOL: Programa para el visionado de estructuras moleculares tridimensionales. 
 
PROCEDIMIENTO EXPERIMENTAL 

1.- CREACION DE UNA CARPETA DE TRABAJO:  

Generamos en el escritorio una carpeta de trabajo que nombraremos “Proyecto” en la que 
tenemos que incluir una copia de los programas de docking así como de los ficheros de 
parámetros (podemos encontrarlos en el campus virtual):  

. - autodock.exe . - AD4_parameters.dat 

. - autogrid.exe . - AD4.1_bound.dat  
 

2.- OBTENCION DE LAS COORDENADAS DE LOS LIGANDOS Y LA PROTEINA MEDIANTE EL USO 
DE BASES DE DATOS  

Vamos a trabajar con los dos enantiómeros del “etil-ibuprofeno”.  

(S)-2-(4-isobutilfenil)propanoato de etilo (R)-2-(4-isobutilfenil)propanoato de etilo 



 

 

2.A) OBTENCION DE LAS COORDENADAS DE LOS LIGANDOS 

Necesitamos los archivos de coordenadas de las estructuras del éster etílico de (R) y (S)-
ibuprofeno, usamos base de datos de estructuras de ligandos ZINC para obtenerlos. 

a) ENTRAMOS EN LA PAGINA DE ZINC: https://zinc.docking.org/ 

 

b) Dibujamos la molécula que queremos descargar en la sección de “subtances”, y pinchamos 
en Default, para que nos busque la molécula que nos interesa 

 
c) Descargamos los ficheros de los dos enantiómeros que nos interesa, para elo: 

.- Seleccionamos cada uno de los ligandos que nos interesa:  

                                 
 

.- Descargamos las coordenadas de cada uno de los ligandos en formato mol2: 
 

(S)-Etil-ibuprofeno (R)-Etil-ibuprofeno 
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2.B) OBTENCION DE LAS COORDENADAS DE LA PROTEINA 

Descargamos la estructura de la proteína de la base de datos PDB, en formato .pdb 

 

3. DOCKING CON AUTODOCK: 

3.A) CONFIGURAR EL ENTORNO DE TRABAJO: 

Definimos en el programa de AutodockTools, donde está la carpeta con la que vamos a trabajar. 
Es necesario que todos los ficheros de coordenadas tanto de la proteína como del ligando, así 
como los programas de cálculo de las grids de interacción (autogrid.exe), de docking 
(autodock.exe) y de parámetros (AD4_parameters.dat, AD4.1_bound.dat) se encuentren en la 
misma carpeta de trabajo. 

“File” → “Preference” → “Set” → “Cambiamos el path en Startup Directory” → “Set” 

(1) 

 

(2) 

 

 
3B) PASO 1. CREAMOS LOS FICHEROS PDBQT CON AUTODOCKTOOLS 



Autodock solo tiene en cuenta los H polares, no tiene en cuenta los H unidos a los átomos de 
carbono. Usa como fichero de coordenadas un fichero PDB extendido, es un fichero PDBQT.  

PDBQT incluye: 

1) Átomos de hidrógeno polares 
2) Cargos parciales 
3) Tipos de átomos 
4) Información sobre la articulación de moléculas flexibles. 
Creamos dos archivos separados de coordenadas *pdbqt uno para el receptor y uno para 
el ligando.  

PREPARACIÓN DEL LIGANDO: Consta de dos etapas, preparación del fichero de coordenadas, 
creación del fichero pdbqt. 

1.- Abrimos el fichero *.mol2 en AutodockTools y lo guardamos en formato *.pdb cambiando el 
nombre del fichero del ligando, es importante hacer este cambio de formato para poder 
continuar con la preparación del ligando. (El programa de docking esta creado de manera que 
la longitud de los nombres de los ficheros no sea demasiado largo, y no lleven caracteres 
distintos a las letras como guiones o asteriscos o puntos) 

“File” → “Read Molecule” → “Save” → “Write PDB" → “ligandoS.pdb” 
2.- Volvemos a AutodockTools y borramos todo lo que tenemos en la pantalla. 

“Edit” → “Delete” → “Delete all molecules 
  

(1) 

 

(2) 

 
3.- Abrimos ahora el fichero ligandoS.pdb en Autodock.  

“File” → “Read Molecule” → “ligandoS.pdb” 

4.- Comenzamos a preparar el ligando con el menú EDIT de AutodockTools:  

4.1) Agregue átomos de hidrógeno a la molécula 

“Edit” → “Hydrogens” → “Add” → “OK” 

4.2) Agregue cargos parciales. Vamos a seleccionar las cargas de tipo GASTEIGER.  

“Edit” → “Charges” → “Compute Gasteiger” → “Aceptar” 

4.3) Fijamos el enlace éster como no rotable desde el menú Select.  

“Select” → “Select from String” → “ATOM: O3,C4,O5” → “Add” → “Dismiss” 
 



En La ventana emergente escribiremos el 
nombre de los átomos que están 
involucrados en los enlaces que queremos 
fijar, para ello escribimos en la ventana de 
“ATOM: O3,C4,O5” y seleccionamos la 
opción “Add”.  
 

 
 

5) Salvamos el fichero “*.pdbqt” del ligando, para ello trabajamos con el menú Ligand. 
Empezamos seleccionando nuestro ligando como molécula para realizar el docking, en este 
momento el programa elimina los H no polares y comprueba que la molécula tenga las cargas 
parciales calculadas. 

“Ligand” → “Input” → “Choose” → SLigando → “Select Molecule for Autodock4” → “Aceptar” 

6) Definimos los enlaces rotables y construimos el árbol de torsión.  

“Ligand” → “Torsion Tree” → “Choose Torsions” → “Make bonds between selected atoms 
non rotatables” → “Done” 

 

 

6) Salvamos el ligando en formato “PDBQT”  

“Ligand” → “Output” → “Save as PDBQT” → “SLigando.pdbqt” → “Guardar” 

PREPARACIÓN DE LA PROTEINA: Consta de dos etapas, preparación del fichero de coordenadas, 
creación del fichero *.pdbqt. 

1.- Abrimos el fichero 1crl.pdb en AutodockTools y comenzamos a prepararlo para el docking 

“File” → “Read Molecule” → “1crl.pdb” → “Abrir” 

2.- Tenemos que eliminar de las coordenadas de la proteína todo aquello que el programa no 
vaya a utilizar para realizar el docking, como moléculas de H2O y heteroátomos. Primero 
seleccionamos las moléculas que queremos eliminar y después las borramos.  

Selección:  

“Select” → “Select from String” → ”rellenamos la ventana emergente”→ “Add” → “Dismiss” 
 



En la ventana emergente, rellenamos 
las secciones 
Residue: HOH*, NAG* 
Atom: hetatm 
 

 
 
Eliminación: 

“Edit” → “Delete” → “Delete Selected Atoms” → “CONTINUE” 

3. Añadimos hidrógenos a la proteína. 

“Edit” → “Hydrogens” → “Add” 

4.- Calculamos las cargas parciales de los distintos átomos de la proteína. 

“Edit” → “Charges” → “Compute Gasteiger” 

COMENZAMOS CON EL MENU FLEXIBLE RESIDUE que define los rotables de la proteína. 

5.- Elegimos la proteína que queremos utilizar. 

“Flexible Residue” → “Input” → “Choose Macromolecule” → “1crl” → “Select Molecule” → 
“Yes” → “Aceptar” 

 
6.- Calculamos los enlaces rotables de los residuos de la proteína que queremos que sea 
flexibles. Elegimos la Serina-209 que interacciona directamente con el ligando y que forma parte 
de la triada catalítica. Para su selección usamos el menú Select.  

“Select” → “Select from String” → “Residue: SER209” → “Add” → “Dismiss” 

Ahora calculamos los enlaces rotables del residuo elegido. 

“Flexible Residue” → “Choose Torsion in Currently Selected Residues” → “Close” 

7.- Volvemos a cargar la macromolécula, es decir la proteína. 

“Flexible residue” → “Redisplay Macromolecule” 

8.- Salvamos los ficheros *.pdbqt de la proteína, la parte flexible que será el residuo SER209 y el 
resto de la proteína la salvaremos como proteína rígida. 



“Flexible Residue” → “Output” → “Save Flexible PDBQT” → proteina-flexible.pdbqt → 
“Guardar” 

“Flexible Residue” → “Output” → “Save Rigid PDBQT” → proteina-rigida.pdbqt →  
“Guardar” 

 

 

4) PASO 2.  PREPARAMOS LOS FICHEROS PARA CALCULAR LA GRID CON AUTODOCKTOOLS 

Una vez que tenemos preparados los ficheros de la proteína y el ligando, el paso siguiente es 
calcular la grid de energía. Para agilizar el cálculo de energía de interacción entre la proteína y 
el ligando autogrid precálcula la energía de interacción de varios tipos de átomos (C alifático, C 
aromático, Oxígeno dador o aceptor de enlace de hidrogeno, etc) así como potenciales 
electrostáticos y de desolvatación. El programa calcula una malla de puntos de interacción que 
luego usara AutoDock para realizar los cálculos de energía de interacción de docking. 

1.- Comenzamos a calcular la grid borrando todos los ficheros que hay cargados en 
AutodockTools hasta este momento. 

“Edit” → “Delete“→  “Delete All Molecules” 

 
Vamos a usar el menú GRID para preparar el fichero grid.gpf que contiene las ordenes necesarias 
para calcular la grid de energía de interacción.  

2.- Seleccionamos el fichero de proteína-rigida.pdbqt como macromolécula en la que calcular la 
grid de interacciones. Al final del proceso aparece una ventana preguntando si se desea 
mantener las cargas de la proteína, presionamos NO para volver a calcular las cargas gasteiger, 
así nos aseguramos de que son correctas. 

“Grid” → “Macromolecule” → “Open” → “proteina-rigida.pdbqt” → “No” 

3.- Elegimos el tipo de átomos que vamos a usar para calcular la grid. Es importante que todos 
los átomos que forman la proteína estén representados, incluyendo los H polares. 

“Grid” → “Set MapTypes” → “Directly” → “Accept” 

4.- Elegimos el tamaño de la caja, el espacio entre los puntos de grid y el centro de la caja. Al 
realizar el docking el programa autodock procurará que el centro del ligando coincida con el 
centro de la caja. 

“Grid” → “Grid Box” 
 



• Tamaño de la caja: 40 x 40 x 40 
• Espacio entre los puntos de grid: 0,375 Å 
• Coordenadas (x,y,z) del centro de la caja 

de grid: (63.793, 57.521, -15.993) 

 

5.- Salvamos las características de la caja en un fichero de texto y cerramos la ventana 

“File” “Output grid dimensions file” → “grid.txt” 

“File” → “Close Saving Currents” 

6.- Salvamos el fichero con las órdenes para calcular la grid. 

“Grid” → “Output Save GPF” → “grid.gpf” 
 

5) PASO 3.  PREPARAMOS LOS FICHEROS PARA CALCULAR EL DOCKING CON AUTODOCKTOOLS 

Vamos a usar el menú Docking para preparar el fichero dock.dpf que contiene las ordenes 
necesarias para calcular el docking. 

1.- Elegimos la proteína en la que vamos a realizar el docking. Le indicamos al programa que 
parte de la proteína es rígida y que parte de la proteína es flexible, seleccionando los ficheros 
*.pdbqt que creamos en el PASO 1. 

“Docking → “Macromolecule” → “Set Rigid Filename” → “proteina-rigida.pdbqt” 

“Docking” → “Macromolecule” → “Set Flexible Filename” → “proteina-flexible.pdbqt” 

2.- Elegimos el Ligando que queremos hacer interaccionar con la proteína. 

“Docking” → “Ligand” → “Open” → “Sligando.pdbqt” → “Accept” 

3.- Elegimos el tipo de algoritmo de búsqueda que se va a utilizar para realizar el docking. 

“Docking” → “Search Parameters” → “Genetic Algorithm Parameters” → “Accept” 

4.- Elegimos los parámetros de docking 

“Docking” → “Docking Parameters” → “Accept” 

5.- Salvamos el fichero con las órdenes para realizar los cálculos de docking. El método más 
eficiente es un algoritmo genético lamarckiano (LGA), también se encuentran disponibles otros 
algoritmos. 

“Docking” → “Output” → “Lamarckina GA(4.2)” → “docking.dpf” 
 



6) PASO 4.  LANZAMOS AUTOGRID USANDO AUTODOCKTOOLS 

Vamos a utilizar el menú Run para lanzar los distintos programas de cálculo, el primero que 
debemos lanzar el autogrid, para tener los puntos de interacción precalculados que luego usará 
el algoritmo de autodock. Al final del cálculo se generan mapas de energía que se guardan en 
nuestra capeta de cálculo con la extensión*.map. Tendremos un mapa de energía por cada tipo 
de átomo que hayamos elegido en el PASO 2. 

1.- Abrimos el menú Run y seleccionamos Run Autogrid, en la ventana de dialogo lo único que 
debemos rellenar es el nombre con el que salvar el fichero de registro (log) 

“Run” → “Run Autogrid” 

“autogrid4 -p C:/Users/Almudena/Desktop/project/4.2.6/grid.gpf -l grid.glg &” 

“Launch” 
 

 

6) PASO 5.  LANZAMOS AUTODOCK USANDO AUTODOCKTOOLS 

1.- Una vez precalculada la grid lanzamos los cálculos de docking desde el menú Run. Para 
obtener 10 soluciones por ligando el programa tardará uso 10 minutos dependiendo de las 
capacidades del ordenador donde se realiza el cálculo. Lo único que debemos rellenar es el 
nombre con el que salvar el fichero de registro (log) 

 

“Run” → “Run Autodock” 

“autodock4 -p docking.dpf -l docking.dlg &” 

“Launch” 



 

7) PASO 6. ANALISIS DE RESULTADOS CON USANDO AUTODOCKTOOLS Y PYMOL 

AutoDockTools incluye varios métodos para analizar los resultados de las simulaciones de 
docking, incluidas las herramientas para agrupar los resultados por similitud conformacional 
(cluster), visualización de conformaciones, visualización de interacciones entre ligandos y 
proteínas, y visualizar los potenciales de afinidad creados por AutoGrid. Usamos el menú 
Analyze para analizar los resultados de docking y salvarlos en formato pdb o pdbqt para poder 
visualizarlos en otros programas de visionado como pymol o chimera. 

1. Cargamos los resultados de docking en AutodockTools, vamos a trabajar con el menú 
Analyze. 

“Analyze” → “Dockings” → “Open” → “Docking.dlg” → “Aceptar” 
 

2. Cargamos la estructura de la proteína para ver cómo interacciona con el ligando una 
vez hecho el docking. 

“Analyze” → ““Macromolecule” → “Open” → “proteína-rígida.pdbqt” 

3. Vemos las distintas conformaciones que adopta el ligando en el sitio activo de la 
proteína. 

“Analyze” → “Conformations” → “Play, ranked by energy” 

4. Para poder analizar la convergencia de los resultados de docking agrupamos las 
soluciones en función de su energía de interacción y de su conformación. 
  

“Analyze” → “Clustering” → “Show” 
 



 
5. Pinchamos sobre el cluster más poblado que además es el de menor energía, y 

desplegamos las opciones de cada una de las soluciones.  
En el menú “Set Play Option” vamos a construir los puentes de Hidrógeno, Escribir las 
soluciones en la carpeta de trabajo. 

 
 

6. El programa AutodockTools nos muestra también las interacciones de cada una de las 
soluciones con la proteína, usando en el menú “Analyze” la opción de “Show 
Interactions”. 

“Analyze” → “Dockings” → “Show Interactions” 

 
 



Una vez analizamos los resultados de docking del ligando (S) borramos todas las moléculas de 
la pantalla y comenzamos el docking con el ligando (R) para ellos seguimos todos los pasos 
descritos anteriormente.  

8) COMPARACION DE LOS RESULTADOS DE DOCKING CON EL PROGRAMA DE VISIONADO 
PYMOL.  
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